Îõ³h&;é3“      !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~€�‚ƒ„…†‡ˆ‰Š‹Œ�Ž��‘’“”•–—˜™š›œ�žŸ ¡¢£¤¥¦§¨©ª«¬­®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖרÙÚÛÜÝÞßàáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿ€�‚ƒ„…†‡ˆ‰Š‹Œ�Ž��‘’“”•–—˜™š›œ�žŸ ¡¢£¤¥¦§¨©ª«¬­®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖרÙÚÛÜÝÞßàáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿ€�‚ƒ„…†‡ˆ‰Š‹Œ�Ž��‘’ Safe-Inferred" g cloudflare-apiœResult type for Cloudflare API calls that returns a result with meta information about the result, a list of errors, a list of messages, and a success flagcloudflare-apiøResult type for Cloudflare API calls that returns a result with a list of errors, a list of messages, and a success flag cloudflare-apiÉResult information for Cloudflare API calls that return a list of resultscloudflare-api-Additional messages from Cloudflare API callscloudflare-api*Result type for Cloudflare API call errorscloudflare-apiîResult type for Cloudflare API calls that don't return any extra data and wrap the result in a "result" fieldcloudflare-apiCloudflare account information cloudflare-apiCloudflare account ID!cloudflare-apiCloudflare account name"cloudflare-apiCloudflare API token see  Ìhttps://developers.cloudflare.com/fundamentals/api/get-started/create-token/% for instructions on creating a token%  ! "$#%"$#!    Safe-Inferred"2×Ü-ëñAcloudflare-apiRFC 7553 URI recordCcloudflare-api!URI content, defined in section 2Dcloudflare-api;Priority, lower value means higher chance of being selectedEcloudflare-api.RFC 1035 TXT record, defined in section 3.3.14Gcloudflare-apiText content of the recordHcloudflare-api*RFC 6698 TLSA record, defined in section 2Jcloudflare-api÷Certificate, either raw data (full certificate or SubjectPublicKeyInfo based on the selector) for matching type 0, or the hash of the raw certificate data for types 1 and 2. The hash is in binary form, not hex-encoded. Defined in section 2.1.4Kcloudflare-apiÞMatching type specifies how the certificate association is presented, defined in section 2.1.3Lcloudflare-apiÓSelector the part of the TLS certificate to match against, defined in section 2.1.2Mcloudflare-api3Usage of the certificate, defined in section 2.1.1 Ncloudflare-api*draft-ietf-dnsop-svcb-https-12 SVCB recordPcloudflare-apiPriorityQcloudflare-apiTargetRcloudflare-apiÂValue (Example 'alpn="h3,h2" ipv4hint="127.0.0.1" ipv6hint="::1"')Scloudflare-apiRFC 4255 SSHFP recordUcloudflare-api AlgorithmVcloudflare-api FingerprintWcloudflare-apiTypeXcloudflare-apiRFC 2782 SRV, service recordZcloudflare-apiDomain name of the service[cloudflare-apiThe port of the service\cloudflare-apiõThe priority of the target host, client MUST attempt to contact the target host with the lowest priority it can reach]cloudflare-apiÄName of the protocol for the service, prepended with an underscore (_TCP, _UDP)^cloudflare-api5A service type, prefixed with an underscore (Example _SIP"), defined in RFC 1700 or locally _cloudflare-api9Domain name of the target host, there can not be an alias`cloudflare-apiæRelative weight for records with the same priority, higher value means higher chance of being selectedacloudflare-apiRFC 8162 SMIMEA recordccloudflare-api Certificatedcloudflare-api Matching typeecloudflare-apiSelectorfcloudflare-apiUsagegcloudflare-api6RFC 1035 PTR, pointer record defined in section 3.3.12icloudflare-apiA valid PTR target host namejcloudflare-api9RFC 1035 NS, name server record defined in section 3.3.11lcloudflare-api%A domain name to act as a name servermcloudflare-api-RFC 3403 NAPTR, Name Authority Pointer recordocloudflare-api‚Flags to control the rewriting and interpretation of the fields in the record, characters from A-Z and 0-9, defined in section 4.1pcloudflare-apiÃOrder that the records MUST be processed in, defined in section 4.1qcloudflare-apiÂPreference, equivalent to priority in DDDS, defined in section 4.1rcloudflare-apiÞRegexp, substitution expression that is applied to the original string, defined in section 4.1scloudflare-apiÊReplacement, MUST be a fully qualified domain name, defined in section 4.1tcloudflare-apiÍService parameters applicable to this delegation path, defined in section 4.1ucloudflare-api,RFC 1035 MX record, defined in section 3.3.9wcloudflare-api'A domain name to act as a mail exchangexcloudflare-apiñPriority of the target host, client MUST attempt to contact the target host with the lowest priority it can reachycloudflare-api)RFC 1876 LOC record, defined in section 2{cloudflare-apiýAltitude of location in meters from 0e0 to 9e9, from a base of 100,000 meters below the WGS 84 reference spheroid used by GPS|cloudflare-apiDegrees of latitude}cloudflare-api=Direction of latitude (N or S) TODO make this a specific type~cloudflare-apiMinutes of latitudecloudflare-api/Seconds of latitude rounded to 3 decimal places€cloudflare-apiDegrees of longitude�cloudflare-api>Direction of longitude (E or W) TODO make this a specific type‚cloudflare-apiMinutes of longitudeƒcloudflare-api0Seconds of longitude rounded to 3 decimal places„cloudflare-api*Horizontal precision of location in meters…cloudflare-api8Vertical precision of location in meters from 0e0 to 9e9†cloudflare-api*Size of location in meters from 0e0 to 9e9‡cloudflare-apiéDefined in section 1.2 of draft-ietf-dnsop-svcb-https-12, it shares the same structure as the SVCB record‰cloudflare-apipriorityŠcloudflare-apitarget‹cloudflare-api5value TODO this could be made into a [(Text, Text))] Œcloudflare-api)RFC4034 DS record, defined in section 5.1Žcloudflare-api&Algorithm, defined in 5.1.2 of RFC4034�cloudflare-api#Digest, defined in 5.1.4 of RFC4034�cloudflare-api(Digest type, defined in 5.1.3 of RFC4034‘cloudflare-api$Key tag, defined in 5.1.1 of RFC4034’cloudflare-api+RFC4034 DNSKEY record, defined in section 2”cloudflare-api&Algorithm, defined in 2.1.3 of RFC4034•cloudflare-api8Flags for the DNSKEY record, defined in 2.1.1 of RFC4034–cloudflare-api;Protocol for the DNSKEY record, defined in 2.1.2 of RFC4034—cloudflare-apiäPublic key for the DNSKEY record, depends on the algorithm used, see appendix section A.1 of RFC4034˜cloudflare-api$RFC 1035 CNAME record, section 3.3.1šcloudflare-api)Domain name to which the record points to›cloudflare-apiRFC4398 CERT record �cloudflare-api&Algorithm, defined in 2.1.3 of RFC4034žcloudflare-api CertificateŸcloudflare-api)Key tag, defined in appendix B of RFC4034 cloudflare-api(Type, section 2.1 of RFC4398 1 for X.509¡cloudflare-apiRFC 6844 CAA record£cloudflare-api/Flags for the CAA record see RFC 6844 section 1¤cloudflare-apiéName of the property controlled by this record (e.g.: issue, issuewild, iodef). TODO make a specific type¥cloudflare-apiÅValue of the record. This field's semantics depend on the chosen tag.¦cloudflare-apiRFC 3596 AAAA record¨cloudflare-apiValid IPv6 address.©cloudflare-apiRFC 1035 A record«cloudflare-apiValid IPv4 address.¬cloudflare-api"Create a new DNS record for a zone®cloudflare-apiThe data for the DNS record¯cloudflare-api4DNS record name (or @ for the zone apex) in Punycode°cloudflare-api)Use Cloudflare's proxying for this record±cloudflare-apiÑComments or notes about the DNS record. This field has no effect on DNS responses²cloudflare-apiéCustom tags for the DNS record. This field has no effect on DNS responses. Not available in the free plan³cloudflare-apiÄTime To Live (TTL) of the DNS record in seconds. Setting to 1 means  automaticÚ. Value must be between 60 and 86400, with the minimum reduced to 30 for Enterprise zones.´cloudflare-api+DNS entries returned by the Cloudflare API ·cloudflare-apiDNS record type¸cloudflare-apiDNS record content¹cloudflare-apiÑComments or notes about the DNS record. This field has no effect on DNS responsesÀcloudflare-apiÊCustom tags for the DNS record. This field has no effect on DNS responses.Ácloudflare-apiÄTime To Live (TTL) of the DNS record in seconds. Setting to 1 means  automaticÚ. Value must be between 60 and 86400, with the minimum reduced to 30 for Enterprise zones.Âcloudflare-apiZone identifierÃcloudflare-api Zone nameâcloudflare-apiNumber of DNS records addedãcloudflare-api"Total number of DNS records parsedäcloudflare-api"Create a new DNS record for a zoneåcloudflare-apiList DNS records for a zoneæcloudflare-api*Export a zone's DNS records in BIND formatçcloudflare-api!Import DNS records in BIND formatècloudflare-apiScan DNS records for a zoneécloudflare-apiDelete a DNS recordêcloudflare-apiGet a single DNS record forëcloudflare-apiPatch a DNS recordìcloudflare-apiUpdate a DNS record Åcloudflare-api6Type of the record and a list the fields of the recordÆcloudflare-apiDNS record typeÇcloudflare-apiParse the fields of the recordäcloudflare-apiZone Identifieråcloudflare-apiZone Identifieræcloudflare-apiZone identifiercloudflare-apiExported BIND zone fileçcloudflare-apiZone identifiercloudflare-api Bind configcloudflare-api0If true, proxy the DNS record through Cloudflareècloudflare-apiZone identifierécloudflare-apiZone identifiercloudflare-apiDNS identifierêcloudflare-apiZone identifiercloudflare-apiDNS identifierëcloudflare-apiZone identifiercloudflare-apiDNS identifierìcloudflare-apiZone identifiercloudflare-apiDNS identifier­ADCBEGFHMLKJINRQPOSWVUTX`_^]\[ZYafedcbgihjlkmtsrqponuxwvy†…„ƒ‚�€~}|{z‡‹Š‰ˆŒ‘��Ž�’—–•”“˜š™› Ÿž�œ¡¥¤£¢¦¨§©«ª¬³²±°¯®­´ÃÂÁÀ¿¾½¼»º¹¸·¶µÄÇÆÅÈÜÛÚÙØ×ÖÕÔÓÒÑÐÏÎÍÌËÊÉÝßÞàãâáäåæçèéêëìí­äåæçèéêëìàãâáÝßÞÈÜÛÚÙØ×ÖÕÔÓÒÑÐÏÎÍÌËÊÉíÄÇÆÅ´ÃÂÁÀ¿¾½¼»º¹¸·¶µ¬³²±°¯®­©«ª¦¨§¡¥¤£¢› Ÿž�œ˜š™’—–•”“Œ‘��Ž�‡‹Š‰ˆy†…„ƒ‚�€~}|{zuxwvmtsrqponjlkgihafedcbX`_^]\[ZYSWVUTNRQPOHMLKJIEGFADCB Safe-Inferred"2#äcloudflare-apiStatus of DNSSec for a zoneçcloudflare-apiÊEdit DNSSEC settings for a zone, fields set to Nothing will not be changedécloudflare-api%Enable or disable multi-signer DNSSECêcloudflare-api"Enable or disable presigned DNSSECëcloudflare-apiEnable or disable DNSSECìcloudflare-api"Get the DNSSEC settings for a zoneícloudflare-apiEdit DNSSEC settings for a zoneîcloudflare-api#Text representation of DNSSECStatusÒßÞÝÜÛÚÙØ×ÖÕÔÓàãâáäæåçëêéèìíîìíçëêéèäæåîàãâáÒßÞÝÜÛÚÙØ×ÖÕÔÓ Safe-Inferred"2Ü2Âÿ�Œ‹Š‰ˆ‡†…„ƒ‚�€ŽŽÿ�Œ‹Š‰ˆ‡†…„ƒ‚�€“        !"#$%&'()*+,-./0123456789:;<=>>?@AABCCDEFGHHIJKLLMNOPPQRSTUVWXXYZ[\]]^__`aabcdefghhijkklmnopqrstuvwxxyz{||}~€��‚ƒ„…††‡ˆˆ‰Š‹Œ��Ž��‘‘’““”••–—˜™š›œœ�žŸ ¡¢£¤¥¦§¨©ª«¬­®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÄÅÆÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖרÙÚÛÜÝÞßàáâãäåæçèéêëìíîïðñòóôõö÷øùúûüýþÿ€�‚ƒ„…†‡ˆ‰Š‹Œ�Ž��‘’“”•–—˜™š›œ�žŸ ¡¢£¤¥¦§¨©ª«¬­®¯°±²³´µ¶··¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËËÌÍÎÏÐÑÒÓÔÕÖרÙÚÛÜÝÞßàáââãäåæçèéêëìíîïðñòóôõcloudflare-api-0.1.0.0-inplaceNetwork.Cloudflare.TypesNetwork.Cloudflare.DNS.RecordNetwork.Cloudflare.DNS.DNSSECNetwork.Cloudflare.ZoneResultWithInforesultWithInfoInforesultWithInfoErrorsresultWithInfoMessagesresultWithInfoSuccessresultWithInfoResultResultResponse resultErrorsresultMessages resultSuccess resultResult ResultInforesultInfoCountresultInfoPageresultInfoPerPageresultInfoTotalCountResponseMessageresponseMessageCoderesponseMessageMessage ResponseErrorresponseErrorCoderesponseErrorMessage ResultOnlyresultOnlyResultAccount accountId accountNameCloudflareAuthcloudflareAuthToken$fFromJSONAccount$fFromJSONResultOnly$fFromJSONResponseError$fFromJSONResponseMessage$fFromJSONResultInfo$fFromJSONResultResponse$fFromJSONResultWithInfo$fEqResultWithInfo$fOrdResultWithInfo$fShowResultWithInfo$fEqResultResponse$fOrdResultResponse$fShowResultResponse$fEqResultInfo$fOrdResultInfo$fShowResultInfo$fEqResponseMessage$fOrdResponseMessage$fShowResponseMessage$fEqResponseError$fOrdResponseError$fShowResponseError$fEqResultOnly$fOrdResultOnly$fShowResultOnly $fEqAccount $fOrdAccount $fShowAccount URIRecorduriRecordContenturiRecordPriority TXTRecordtxtRecordContent TLSARecordtlsaRecordCertificatetlsaRecordMatchingTypetlsaRecordSelectortlsaRecordUsage SVCBRecordsvcBRecordPrioritysvcBRecordTargetsvcBRecordValue SSHFPRecordsshfpRecordAlgorithmsshfpRecordFingerprintsshfpRecordType SRVRecord srvRecordName srvRecordPortsrvRecordPrioritysrvRecordProtosrvRecordServicesrvRecordTargetsrvRecordWeight SMIMEARecordsmimeaRecordCertificatesmimeaMathingTypesmimeaRecordSelectorsmimeaRecordUsage PTRRecordptrRecordContentNSRecordnsRecordContent NAPTRRecordnaptrRecordFlagsnaptrRecordOrdernaptrRecordPreferencenaptrRecordRegexpnaptrRecordReplacementnaptrRecordServiceMXRecordmxRecordContentmxRecordPriority LOCRecordlocRecordAltitudelocRecordLatDegreeslocRecordLatDirectionlocRecordLatMinuteslocRecordLatSecondslocRecordLongDegreeslocRecordLongDirectionlocRecordLongMinuteslocRecordLongSecondslocRecordPrecisionHorizlocRecordPrecisionVert locRecordSize HTTPSRecordhttpsRecordPriorityhttpsRecordTargethttpsRecordValueDSRecorddsRecordAlgorithmdsRecordDigestdsRecordDigestTypedsRecordKeyTag DNSKEYRecorddnskeyRecordAlgorithmdnskeyRecordFlagsdnskeyRecordProtocoldnskeyRecordPublicKey CNAMERecordcnameRecordContent CERTRecordcertRecordAlgorithmcertRecordCertificatecertRecordKeyTagcertRecordType CAARecordcaaRecordFlags caaRecordTagcaaRecordValue AAAARecordaaaaRecordContentARecordaRecordContentCreateDNSRecordcreateDNSRecordDatacreateDNSRecordNamecreateDNSRecordProxiedcreateDNSRecordCommentcreateDNSRecordTagscreateDNSRecordTTLDNSRecordEntrydnsRecordEntryDatadnsRecordEntryTypednsRecordEntryContentdnsRecordEntryCommentdnsRecordEntryCreatedOndnsRecordEntryIddnsRecordEntryLockeddnsRecordEntryMetadnsRecordEntryModifiedOndnsRecordEntryProxiablednsRecordEntryTagsdnsRecordEntryTTLdnsRecordEntryZoneIddnsRecordEntryZoneName DNSRecorddnsRecordToJSON dnsRecordTypednsRecordParseDNSEntry ARecordEntryAAAARecordEntryCAARecordEntryCERTRecordEntryCNAMERecordEntryDNSKEYRecordEntry DSRecordEntryHTTPSRecordEntryLOCRecordEntry MXRecordEntryNAPTRRecordEntry NSRecordEntryPTRRecordEntrySMIMEARecordEntrySRVRecordEntrySSHFPRecordEntrySVCBRecordEntryTLSARecordEntryTXTRecordEntryURIRecordEntry DNSIdentifierdnsIdentifierIdImportResponseimportResponseRecsAdded importResponseTotalRecordsParsedcreateDNSRecordlistDNSRecordsexportDNSRecordsimportDNSRecordsscanDNSRecordsdeleteDNSRecorddnsRecordDetailspatchDNSRecordupdateDNSRecord withDNSEntry$fFromJSONImportResponse$fFromJSONDNSIdentifier$fFromJSONDNSRecordEntry$fToJSONCreateDNSRecord$fDNSRecordARecord$fDNSRecordAAAARecord$fDNSRecordCAARecord$fDNSRecordCERTRecord$fDNSRecordCNAMERecord$fDNSRecordDNSKEYRecord$fDNSRecordDSRecord$fDNSRecordHTTPSRecord$fDNSRecordLOCRecord$fDNSRecordMXRecord$fDNSRecordNAPTRRecord$fDNSRecordNSRecord$fDNSRecordPTRRecord$fDNSRecordSMIMEARecord$fDNSRecordSRVRecord$fDNSRecordSSHFPRecord$fDNSRecordSVCBRecord$fDNSRecordTLSARecord$fDNSRecordTXTRecord$fDNSRecordURIRecord$fFromJSONDNSEntry $fEqDNSEntry $fOrdDNSEntry$fShowDNSEntry $fEqURIRecord$fOrdURIRecord$fShowURIRecord $fEqTXTRecord$fOrdTXTRecord$fShowTXTRecord$fEqTLSARecord$fOrdTLSARecord$fShowTLSARecord$fEqSVCBRecord$fOrdSVCBRecord$fShowSVCBRecord$fEqSSHFPRecord$fOrdSSHFPRecord$fShowSSHFPRecord $fEqSRVRecord$fOrdSRVRecord$fShowSRVRecord$fEqSMIMEARecord$fOrdSMIMEARecord$fShowSMIMEARecord $fEqPTRRecord$fOrdPTRRecord$fShowPTRRecord $fEqNSRecord $fOrdNSRecord$fShowNSRecord$fEqNAPTRRecord$fOrdNAPTRRecord$fShowNAPTRRecord $fEqMXRecord $fOrdMXRecord$fShowMXRecord $fEqLOCRecord$fOrdLOCRecord$fShowLOCRecord$fEqHTTPSRecord$fOrdHTTPSRecord$fShowHTTPSRecord $fEqDSRecord $fOrdDSRecord$fShowDSRecord$fEqDNSKEYRecord$fOrdDNSKEYRecord$fShowDNSKEYRecord$fEqCNAMERecord$fOrdCNAMERecord$fShowCNAMERecord$fEqCERTRecord$fOrdCERTRecord$fShowCERTRecord $fEqCAARecord$fOrdCAARecord$fShowCAARecord$fEqAAAARecord$fOrdAAAARecord$fShowAAAARecord $fEqARecord $fOrdARecord $fShowARecord$fEqCreateDNSRecord$fOrdCreateDNSRecord$fShowCreateDNSRecord$fEqDNSRecordEntry$fOrdDNSRecordEntry$fShowDNSRecordEntry$fEqDNSIdentifier$fOrdDNSIdentifier$fShowDNSIdentifier$fEqImportResponse$fOrdImportResponse$fShowImportResponseDNSSECdnssecAlgorithm dnssecDigestdnssecDigestTypednssecMultiSignerdnssecPresigneddnssecDS dnssecFlags dnssecKeyTag dnssecKeyTypednssecModifiedOndnssecPublicKey dnssecStatus DNSECDetails DNSSecActiveDNSSecDisabled DNSSecPending DNSSECStatus DNSSECActiveDNSSECDisabledEditDNSSECStatuseditDNSSECMultiSignereditDNSSECPresignededitDNSSECStatus getDNSSEC editDNSSECdnssecStatusToText$fToJSONDNSSECStatus$fToJSONEditDNSSECStatus$fFromJSONDNSSEC$fFromJSONDNSECDetails$fEqDNSECDetails$fOrdDNSECDetails$fShowDNSECDetails $fEqDNSSEC $fOrdDNSSEC $fShowDNSSEC$fEqEditDNSSECStatus$fOrdEditDNSSECStatus$fShowEditDNSSECStatus$fEqDNSSECStatus$fOrdDNSSECStatus$fShowDNSSECStatusZone zoneAccountzoneActivatedOn zoneCreatedOnzoneDevelopmentModezoneIdzoneMetazoneModifiedOnzoneNamezoneOriginalDNSHostzoneOriginalNameServerszoneOriginalRegistrar zoneOwnerzoneVanityNameServers listZones$fFromJSONZone$fEqZone $fOrdZone $fShowZone